# CVE-2018-20164: uap-core Regular Expression Denial of Service issue

> Remote attackers can cause server overload via ReDoS by sending crafted User-Agent headers to applications using the vulnerable UAP-Core library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-20164, GHSA-fx7m-j728-mjw3

## What is CVE-2018-20164?

CVE-2018-20164 is a medium-severity denial of service vulnerability in n/a, published on 13 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in regex.yaml (aka regexes.yaml) in UA-Parser UAP-Core before 0.6.0. A Regular Expression Denial of Service (ReDoS) issue allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to a value containing a long digit string. (The UAP-Core project contains the vulnerability, propagating to all implementations.)

Weakness: CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2018-20164?

2 open source packages ship an affected version, including uap-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uap-core` | npm | All versions | 0.6.0 |
| `uap-core` | npm | All versions | 0.6.0 |

Products: Uaparser User Agent Parser-Core.

## How do I fix CVE-2018-20164?

Upgrade uap-core to 0.6.0 or later.

## Is CVE-2018-20164 being exploited?

There is no known exploitation of CVE-2018-20164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20164 and fix it if it is affected.

What it is: CVE-2018-20164 is a medium-severity denial of service vulnerability in n/a, published on 13 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20164 in the wild and no public exploit code.

Affected packages and fixed versions:
- uap-core (npm): affected all versions; fixed in 0.6.0
- uap-core (npm): affected all versions; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20164/ (Markdown: https://insights.sbomify.com/CVE-2018-20164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20164
- OSV: https://osv.dev/vulnerability/CVE-2018-20164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20164/
Summaries are generated and may contain mistakes; the official description above is the record.
