# CVE-2018-20227: RDF4J vulnerable to zip slip

> An attacker can read arbitrary files by exploiting directory traversal in ZIP archive entries within the RDF4J library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x3cr-x949-h5jv

## What is CVE-2018-20227?

CVE-2018-20227 is a high-severity path traversal vulnerability in n/a, published on 19 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RDF4J 2.4.2 allows Directory Traversal via ../ in an entry in a ZIP archive.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-20227?

2 open source packages ship an affected version, including org.eclipse.rdf4j:rdf4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.rdf4j:rdf4j` | Maven | All versions | 2.5.0 |
| `org.eclipse.rdf4j:rdf4j` | Maven | All versions | 2.5.0 |

Products: Eclipse Rdf4j.

## How do I fix CVE-2018-20227?

Upgrade org.eclipse.rdf4j:rdf4j to 2.5.0 or later.

## Is CVE-2018-20227 being exploited?

There is no known exploitation of CVE-2018-20227 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000644](https://insights.sbomify.com/CVE-2018-1000644/): Eclipse RDF4j vulnerable to XML External Entity (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20227 and fix it if it is affected.

What it is: CVE-2018-20227 is a high-severity path traversal vulnerability in n/a, published on 19 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20227 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.rdf4j:rdf4j (Maven): affected all versions; fixed in 2.5.0
- org.eclipse.rdf4j:rdf4j (Maven): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20227/ (Markdown: https://insights.sbomify.com/CVE-2018-20227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20227
- OSV: https://osv.dev/vulnerability/CVE-2018-20227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20227/
Summaries are generated and may contain mistakes; the official description above is the record.
