{"answers":{"affected":"2 open source packages ship an affected version, including coherence. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20301 in the wild and no public exploit code.","fix":"Upgrade coherence to 0.5.2 or later.","what":"CVE-2018-20301 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20301 and fix it if it is affected.\n\nWhat it is: CVE-2018-20301 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20301 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- coherence (Hex): affected all versions; fixed in 0.5.2\n- coherence (Hex): affected all versions; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20301/ (Markdown: https://insights.sbomify.com/CVE-2018-20301/index.md)","id":"CVE-2018-20301","markdown":"https://insights.sbomify.com/CVE-2018-20301/index.md","name":"CVE-2018-20301","record":{"aliases":["GHSA-mrq8-53r4-3j5m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir Coherence library","requires_auth":"low_privilege","summary":"Attackers can bypass account confirmation by injecting parameters into registration endpoints, allowing unauthorized access to confirmed accounts.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"coherence","vendor":"coherence_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in Steve Pallen Coherence before 0.5.2 that is similar to a Mass Assignment vulnerability. In particular, \"registration\" endpoints (e.g., creating, editing, updating) allow users to update any coherence_fields data. For example, users can automatically confirm their accounts by sending the confirmed_at parameter with their registration request.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Permissive parameters and privilege escalation","id":"CVE-2018-20301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"business_logic","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site Scripting in xain","id":"CVE-2018-20302"},"packages":[{"ecosystem":"Hex","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"coherence","purl":null,"source":"GHSA-mrq8-53r4-3j5m"},{"ecosystem":"Hex","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"coherence","purl":"pkg:hex/coherence","source":"GHSA-mrq8-53r4-3j5m"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2018-20300"},"products":["n/a"],"published":"2018-12-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass account confirmation by injecting parameters into registration endpoints, allowing unauthorized access to confirmed accounts.","url":"https://insights.sbomify.com/CVE-2018-20301/"}