CVE-2018-20406 Integer overflow in n/a
An integer overflow in Python's pickle module can cause memory exhaustion, leading to denial of service when processing extremely large serialized data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-20406?
CVE-2018-20406 is a high-severity vulnerability in Debian Debian Linux, published on 23 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Modules/_pickle.c in Python before 3.7.1 has an integer overflow via a large LONG_BINPUT value that is mishandled during a "resize to twice the size" attempt. This issue might cause memory exhaustion, but is only relevant if the pickle format is used for serializing tens or hundreds of gigabytes of data. This issue is fixed in: v3.4.10, v3.4.10rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.7rc1, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.7, v3.6.7rc1, v3.6.7rc2, v3.6.8, v3.6.8rc1, v3.6.9, v3.6.9rc1; v3.7.1, v3.7.1rc1, v3.7.1rc2, v3.7.2, v3.7.2rc1, v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.
Weakness: CWE-190
Which versions are affected by CVE-2018-20406?
It affects 3 products.
Products include Debian Debian Linux, Fedoraproject Fedora, Python Python.
How do I fix CVE-2018-20406?
Upgrade to a fixed version.
Is CVE-2018-20406 being exploited?
There is no known exploitation of CVE-2018-20406 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2018-20406, GHSA-p5h6-p5x2-5qxf, PSF-2018-6, UBUNTU-CVE-2018-20406.