{"answers":{"affected":"2 open source packages ship an affected version, including league/commonmark. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20583 in the wild and no public exploit code.","fix":"Upgrade league/commonmark to 0.18.1 or later.","what":"CVE-2018-20583 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-20583 and fix it if it is affected.\n\nWhat it is: CVE-2018-20583 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-20583 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- league/commonmark (Packagist): affected from 0.15.6; fixed in 0.18.1\n- league/commonmark (Packagist): affected from 0.15.6; fixed in 0.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20583/ (Markdown: https://insights.sbomify.com/CVE-2018-20583/index.md)","id":"CVE-2018-20583","markdown":"https://insights.sbomify.com/CVE-2018-20583/index.md","name":"CVE-2018-20583","record":{"aliases":["GHSA-qx76-c53f-5c7q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP CommonMark library","requires_auth":"none","summary":"Remote attackers can inject unsafe URLs via newline characters in the PHP League CommonMark library, bypassing link safety checks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"commonmark","vendor":"thephpleague"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)","id":"CVE-2018-20583","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-20584"},"packages":[{"ecosystem":"Packagist","fixed":["0.18.1"],"introduced":["0.15.6"],"last_affected":[],"package":"league/commonmark","purl":null,"source":"GHSA-qx76-c53f-5c7q"},{"ecosystem":"Packagist","fixed":["0.18.1"],"introduced":["0.15.6"],"last_affected":[],"package":"league/commonmark","purl":"pkg:composer/league/commonmark","source":"GHSA-qx76-c53f-5c7q"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2018-20582"},"products":["n/a"],"published":"2018-12-30","related":[{"cvss_score":8.7,"headline":"commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes","id":"CVE-2026-86428","kev_date_added":null,"published":"2026-09-07"},{"cvss_score":8.7,"headline":"commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes","id":"CVE-2026-86429","kev_date_added":null,"published":"2026-09-07"},{"cvss_score":8.7,"headline":"league/commonmark before 2.9.1 Denial of Service via parsing","id":"CVE-2026-86430","kev_date_added":null,"published":"2026-09-07"},{"cvss_score":6.9,"headline":"commonmark before 2.9.1 XSS via AttributesExtension form feed bypass","id":"CVE-2026-86431","kev_date_added":null,"published":"2026-09-07"},{"cvss_score":6.3,"headline":"league/commonmark has an embed extension allowed_domains bypass","id":"CVE-2026-33347","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":6.1,"headline":"Moderate severity vulnerability that affects league/commonmark","id":"CVE-2019-10010","kev_date_added":null,"published":"2019-03-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can inject unsafe URLs via newline characters in the PHP League CommonMark library, bypassing link safety checks.","url":"https://insights.sbomify.com/CVE-2018-20583/"}