# CVE-2018-20583: PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)

> Remote attackers can inject unsafe URLs via newline characters in the PHP League CommonMark library, bypassing link safety checks.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qx76-c53f-5c7q

## What is CVE-2018-20583?

CVE-2018-20583 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-20583?

2 open source packages ship an affected version, including league/commonmark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 0.15.6 | 0.18.1 |
| `league/commonmark` | Packagist | From 0.15.6 | 0.18.1 |

Products: Thephpleague Commonmark.

## How do I fix CVE-2018-20583?

Upgrade league/commonmark to 0.18.1 or later.

## Is CVE-2018-20583 being exploited?

There is no known exploitation of CVE-2018-20583 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-86428](https://insights.sbomify.com/CVE-2026-86428/): commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes (high 8.7)
- [CVE-2026-86429](https://insights.sbomify.com/CVE-2026-86429/): commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes (high 8.7)
- [CVE-2026-86430](https://insights.sbomify.com/CVE-2026-86430/): league/commonmark before 2.9.1 Denial of Service via parsing (high 8.7)
- [CVE-2026-86431](https://insights.sbomify.com/CVE-2026-86431/): commonmark before 2.9.1 XSS via AttributesExtension form feed bypass (medium 6.9)
- [CVE-2026-33347](https://insights.sbomify.com/CVE-2026-33347/): league/commonmark has an embed extension allowed_domains bypass (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20583 and fix it if it is affected.

What it is: CVE-2018-20583 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-20583 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 0.15.6; fixed in 0.18.1
- league/commonmark (Packagist): affected from 0.15.6; fixed in 0.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20583/ (Markdown: https://insights.sbomify.com/CVE-2018-20583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20583
- OSV: https://osv.dev/vulnerability/CVE-2018-20583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20583/
Summaries are generated and may contain mistakes; the official description above is the record.
