{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2018-20615 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-20615 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 18 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20615 and fix it if it is affected.\n\nWhat it is: CVE-2018-20615 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 18 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20615 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20615/ (Markdown: https://insights.sbomify.com/CVE-2018-20615/index.md)","id":"CVE-2018-20615","markdown":"https://insights.sbomify.com/CVE-2018-20615/index.md","name":"CVE-2018-20615","record":{"aliases":["DEBIAN-CVE-2018-20615","GHSA-w4g5-v736-j48g","RHSA-2019:0275","RHSA-2019:0548","SUSE-SU-2019:0232-1","UBUNTU-CVE-2018-20615","openSUSE-SU-2019:0166-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"An out-of-bounds read in HAProxy's HTTP/2 decoder allows attackers to crash the service via malformed PRIORITY frames.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"haproxy","vendor":"haproxy"},{"product":"leap","vendor":"opensuse"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"openshift_container_platform","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"An out-of-bounds read issue was discovered in the HTTP/2 protocol decoder in HAProxy 1.8.x and 1.9.x through 1.9.0 which can result in a crash. The processing of the PRIORITY flag in a HEADERS frame requires 5 extra bytes, and while these bytes are skipped, the total frame length was not re-checked to make sure they were present in the frame.","ecosystems":["Red Hat:openshift:3.10::el7","Red Hat:rhel_software_collections:3::el7","SUSE:Linux Enterprise High Availability Extension 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-20615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","opensuse:leap","redhat:enterprise_linux","redhat:openshift_container_platform"],"type":"denial_of_service","year":"2018"},"n_packages":7,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-20616"},"packages":[{"ecosystem":"Red Hat:openshift:3.10::el7","fixed":["0:1.8.17-3.el7"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/redhat/haproxy","source":"RHSA-2019:0548"},{"ecosystem":"Red Hat:openshift:3.10::el7","fixed":["0:1.8.17-3.el7"],"introduced":["0"],"last_affected":[],"package":"haproxy-debuginfo","purl":"pkg:rpm/redhat/haproxy-debuginfo","source":"RHSA-2019:0548"},{"ecosystem":"Red Hat:openshift:3.10::el7","fixed":["0:1.8.17-3.el7"],"introduced":["0"],"last_affected":[],"package":"haproxy18","purl":"pkg:rpm/redhat/haproxy18","source":"RHSA-2019:0548"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:1.8.4-4.el7"],"introduced":["0"],"last_affected":[],"package":"rh-haproxy18-haproxy","purl":"pkg:rpm/redhat/rh-haproxy18-haproxy","source":"RHSA-2019:0275"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:1.8.4-4.el7"],"introduced":["0"],"last_affected":[],"package":"rh-haproxy18-haproxy-debuginfo","purl":"pkg:rpm/redhat/rh-haproxy18-haproxy-debuginfo","source":"RHSA-2019:0275"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:1.8.4-4.el7"],"introduced":["0"],"last_affected":[],"package":"rh-haproxy18-haproxy-syspaths","purl":"pkg:rpm/redhat/rh-haproxy18-haproxy-syspaths","source":"RHSA-2019:0275"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15","fixed":["1.8.17~git0.e89d25b2-3.9.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015","source":"SUSE-SU-2019:0232-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2018-20614"},"products":["n/a"],"published":"2019-03-18","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An out-of-bounds read in HAProxy's HTTP/2 decoder allows attackers to crash the service via malformed PRIORITY frames.","url":"https://insights.sbomify.com/CVE-2018-20615/"}