CVE-2018-20663 The Reporting Addon for CUBA Platform has Persistent XSS
Persistent XSS in CUBA Platform Reporting Addon allows attackers to inject scripts via the report name field, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-20663?
CVE-2018-20663 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Reporting Addon (aka Reports Addon) through 2019-01-02 for CUBA Platform through 6.10.x has Persistent XSS via the "Reports > Reports" name field.
Weakness: CWE-79
Which versions are affected by CVE-2018-20663?
6 open source packages ship an affected version, including com.haulmont.cuba:cuba-web-toolkit. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.haulmont.cuba:cuba-web-toolkit Maven | All versions | 6.8.15 |
com.haulmont.cuba:cuba-web-toolkit Maven | All versions | 6.8.15 |
com.haulmont.cuba:cuba-web-toolkit Maven | From 6.10.0 | 6.10.7 |
com.haulmont.cuba:cuba-web-toolkit Maven | From 6.10.0 | 6.10.7 |
com.haulmont.cuba:cuba-web-toolkit Maven | From 6.9.0 | 6.9.8 |
com.haulmont.cuba:cuba-web-toolkit Maven | From 6.9.0 | 6.9.8 |
Products include Haulmont Cuba Platform, Haulmont Reporting.
How do I fix CVE-2018-20663?
Upgrade com.haulmont.cuba:cuba-web-toolkit to a fixed version for your release line: 6.8.15, 6.10.7 or 6.9.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-20663 being exploited?
There is no known exploitation of CVE-2018-20663 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-rff7-964g-pppx.