{"answers":{"affected":"14 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and twbs/bootstrap. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20677 in the wild and no public exploit code.","fix":"Upgrade bootstrap to 3.4.0 or later.","what":"CVE-2018-20677 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-20677 and fix it if it is affected.\n\nWhat it is: CVE-2018-20677 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-20677 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bootstrap (NuGet): affected all versions; fixed in 3.4.0\n- bootstrap (NuGet): affected all versions; fixed in 3.4.0\n- bootstrap (RubyGems): affected all versions; fixed in 3.4.0\n- bootstrap (RubyGems): affected all versions; fixed in 3.4.0\n- bootstrap (npm): affected all versions; fixed in 3.4.0\n- bootstrap (npm): affected all versions; fixed in 3.4.0\n- org.webjars:bootstrap (Maven): affected all versions; fixed in 3.4.0\n- org.webjars:bootstrap (Maven): affected all versions; fixed in 3.4.0\n- twbs/bootstrap (Packagist): affected all versions; fixed in 3.4.0\n- twbs/bootstrap (Packagist): affected all versions; fixed in 3.4.0\n- bootstrap-sass (RubyGems): affected all versions; fixed in 3.4.0\n- bootstrap-sass (RubyGems): affected all versions; fixed in 3.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20677/ (Markdown: https://insights.sbomify.com/CVE-2018-20677/index.md)","id":"CVE-2018-20677","markdown":"https://insights.sbomify.com/CVE-2018-20677/index.md","name":"CVE-2018-20677","record":{"aliases":["AZL-105146","AZL-105161","AZL-105263","AZL-44799","DEBIAN-CVE-2018-20677","GHSA-ph58-4vrj-w6hr","UBUNTU-CVE-2018-20677"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Bootstrap frontend library","requires_auth":"none","summary":"Cross-site scripting vulnerability in Bootstrap allows attackers to inject malicious scripts via the affix configuration target property.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bootstrap","vendor":"getbootstrap"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.","ecosystems":["Maven","NuGet","Packagist","RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"bootstrap Cross-site Scripting vulnerability","id":"CVE-2018-20677","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":14,"n_references":14,"next":{"headline":"LibreNMS SQL Injection","id":"CVE-2018-20678"},"packages":[{"ecosystem":"Maven","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars:bootstrap","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"Maven","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"org.webjars:bootstrap","purl":"pkg:maven/org.webjars/bootstrap","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"NuGet","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"NuGet","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":"pkg:nuget/bootstrap","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"Packagist","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"twbs/bootstrap","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"Packagist","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"twbs/bootstrap","purl":"pkg:composer/twbs/bootstrap","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"RubyGems","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"RubyGems","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":"pkg:gem/bootstrap","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"RubyGems","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-sass","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"RubyGems","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-sass","purl":"pkg:gem/bootstrap-sass","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap","purl":"pkg:npm/bootstrap","source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-sass","purl":null,"source":"GHSA-ph58-4vrj-w6hr"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"bootstrap-sass","purl":"pkg:npm/bootstrap-sass","source":"GHSA-ph58-4vrj-w6hr"}],"prev":{"headline":"XSS vulnerability that affects bootstrap","id":"CVE-2018-20676"},"products":["n/a"],"published":"2019-01-09","related":[{"cvss_score":6.1,"headline":"Bootstrap Cross-site Scripting vulnerability","id":"CVE-2016-10735","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":6.1,"headline":"XSS vulnerability that affects bootstrap","id":"CVE-2018-20676","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":6.1,"headline":"Bootstrap Cross-site Scripting vulnerability","id":"CVE-2018-14041","kev_date_added":null,"published":"2018-07-13"},{"cvss_score":6.1,"headline":"Bootstrap Cross-site Scripting vulnerability","id":"CVE-2018-14042","kev_date_added":null,"published":"2018-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Bootstrap allows attackers to inject malicious scripts via the affix configuration target property.","url":"https://insights.sbomify.com/CVE-2018-20677/"}