# CVE-2018-20678: LibreNMS SQL Injection

> Authenticated users can execute arbitrary SQL commands via the sort parameter in LibreNMS, potentially accessing or modifying database contents.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4fwh-r866-pvh9

## What is CVE-2018-20678?

CVE-2018-20678 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 28 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreNMS through 1.47 allows SQL injection via the html/ajax_table.php sort[hostname] parameter, exploitable by authenticated users during a search.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-20678?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 1.65 |
| `librenms/librenms` | Packagist | All versions | 1.65 |

Products: Librenms Librenms.

## How do I fix CVE-2018-20678?

Upgrade librenms/librenms to 1.65 or later.

## Is CVE-2018-20678 being exploited?

There is no known exploitation of CVE-2018-20678 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20678 and fix it if it is affected.

What it is: CVE-2018-20678 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 28 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20678 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 1.65
- librenms/librenms (Packagist): affected all versions; fixed in 1.65

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20678/ (Markdown: https://insights.sbomify.com/CVE-2018-20678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20678
- OSV: https://osv.dev/vulnerability/CVE-2018-20678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20678/
Summaries are generated and may contain mistakes; the official description above is the record.
