# CVE-2018-20713: Shopware SQL Injection

> Remote authenticated users can execute arbitrary SQL commands in Shopware, potentially accessing or modifying database contents.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-42gv-77f4-r3j9

## What is CVE-2018-20713?

CVE-2018-20713 is a high-severity SQL injection vulnerability in Shopware Shopware, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware before 5.4.3 allows SQL Injection by remote authenticated users, aka SW-21404.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-20713?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 5.4.3 |
| `shopware/shopware` | Packagist | All versions | 5.4.3 |

Products: Shopware Shopware.

## How do I fix CVE-2018-20713?

Upgrade shopware/shopware to 5.4.3 or later.

## Is CVE-2018-20713 being exploited?

There is no known exploitation of CVE-2018-20713 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20713 and fix it if it is affected.

What it is: CVE-2018-20713 is a high-severity SQL injection vulnerability in Shopware Shopware, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20713 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 5.4.3
- shopware/shopware (Packagist): affected all versions; fixed in 5.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20713/ (Markdown: https://insights.sbomify.com/CVE-2018-20713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20713
- OSV: https://osv.dev/vulnerability/CVE-2018-20713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20713/
Summaries are generated and may contain mistakes; the official description above is the record.
