# CVE-2018-20717: PrestaShop PHP Object Injection

> Authenticated attackers with Salesman privileges can achieve remote code execution via PHP object injection in PrestaShop orders.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xx67-2j3v-h76p

## What is CVE-2018-20717?

CVE-2018-20717 is a high-severity unsafe deserialization vulnerability in Prestashop Prestashop, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2018-20717?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.7.2.5 |
| `prestashop/prestashop` | Packagist | All versions | 1.7.2.5 |

Products: Prestashop Prestashop.

## How do I fix CVE-2018-20717?

Upgrade prestashop/prestashop to 1.7.2.5 or later.

## Is CVE-2018-20717 being exploited?

There is no known exploitation of CVE-2018-20717 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20717 and fix it if it is affected.

What it is: CVE-2018-20717 is a high-severity unsafe deserialization vulnerability in Prestashop Prestashop, published on 15 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20717 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.2.5
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20717/ (Markdown: https://insights.sbomify.com/CVE-2018-20717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20717
- OSV: https://osv.dev/vulnerability/CVE-2018-20717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20717/
Summaries are generated and may contain mistakes; the official description above is the record.
