# CVE-2018-20744: github.com/gofiber/fiber/v2 vulnerable to Origin Validation Error

> The Go CORS handler library incorrectly reflects arbitrary Origin headers when wildcard policies are used, allowing attackers to bypass CORS restrictions.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-927h-x4qj-r242, GO-2023-1792

## What is CVE-2018-20744?

CVE-2018-20744 is a medium-severity vulnerability in n/a, published on 28 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Olivier Poitrey Go CORS handler through 1.3.0 actively converts a wildcard CORS policy into reflecting an arbitrary Origin header value, which is incompatible with the CORS security design, and could lead to CORS misconfiguration security problems.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2018-20744?

5 open source packages ship an affected version, including github.com/rs/cors and github.com/gofiber/fiber/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rs/cors` | Go | All versions | 1.5.0 |
| `github.com/rs/cors` | Go | All versions | 1.5.0 |
| `github.com/rs/cors` | Go | All versions | 1.5.0 |
| `github.com/gofiber/fiber/v2` | Go | From 2.0.0 | 2.43.0 |
| `github.com/gofiber/fiber/v2` | Go | From 2.0.0 | 2.43.0 |

Products: Go Cors Project Go Cors.

## How do I fix CVE-2018-20744?

Upgrade github.com/rs/cors to 1.5.0 or later.

## Is CVE-2018-20744 being exploited?

There is no known exploitation of CVE-2018-20744 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20744 and fix it if it is affected.

What it is: CVE-2018-20744 is a medium-severity vulnerability in n/a, published on 28 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20744 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rs/cors (Go): affected all versions; fixed in 1.5.0
- github.com/rs/cors (Go): affected all versions; fixed in 1.5.0
- github.com/rs/cors (Go): affected all versions; fixed in 1.5.0
- github.com/gofiber/fiber/v2 (Go): affected from 2.0.0; fixed in 2.43.0
- github.com/gofiber/fiber/v2 (Go): affected from 2.0.0; fixed in 2.43.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20744/ (Markdown: https://insights.sbomify.com/CVE-2018-20744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20744
- OSV: https://osv.dev/vulnerability/CVE-2018-20744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20744/
Summaries are generated and may contain mistakes; the official description above is the record.
