{"answers":{"affected":"2 open source packages ship an affected version, including modx/revolution. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20758 in the wild and no public exploit code.","fix":"Upgrade modx/revolution to 2.7.1-pl or later.","what":"CVE-2018-20758 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Feb 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-20758 and fix it if it is affected.\n\nWhat it is: CVE-2018-20758 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Feb 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-20758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modx/revolution (Packagist): affected all versions; fixed in 2.7.1-pl\n- modx/revolution (Packagist): affected all versions; fixed in 2.7.1-pl\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20758/ (Markdown: https://insights.sbomify.com/CVE-2018-20758/index.md)","id":"CVE-2018-20758","markdown":"https://insights.sbomify.com/CVE-2018-20758/index.md","name":"CVE-2018-20758","record":{"aliases":["GHSA-vwqw-wfhv-2xcq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MODX CMS","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in MODX Revolution allows attackers to inject malicious scripts via user settings, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"modx_revolution","vendor":"modx"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MODX vulnerability allows for XSS via user settings parameters","id":"CVE-2018-20758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-20760"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.1-pl"],"introduced":["0"],"last_affected":[],"package":"modx/revolution","purl":null,"source":"GHSA-vwqw-wfhv-2xcq"},{"ecosystem":"Packagist","fixed":["2.7.1-pl"],"introduced":["0"],"last_affected":[],"package":"modx/revolution","purl":"pkg:composer/modx/revolution","source":"GHSA-vwqw-wfhv-2xcq"}],"prev":{"headline":"MODX Revolution allows XSS through extended user fields","id":"CVE-2018-20757"},"products":["n/a"],"published":"2019-02-06","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-7321","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-7324","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":9.1,"headline":"XML External Entity vulnerability in MODX CMS","id":"CVE-2020-25911","kev_date_added":null,"published":"2021-10-31"},{"cvss_score":8.8,"headline":"MODX Revolution allows overwriting .htaccess","id":"CVE-2017-9069","kev_date_added":null,"published":"2017-05-18"},{"cvss_score":8.1,"headline":"Weak cryptography in n/a","id":"CVE-2017-7322","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":8.1,"headline":"Server-side request forgery in n/a","id":"CVE-2017-7323","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":7.5,"headline":"File upload in Gallery","id":"CVE-2019-1010123","kev_date_added":null,"published":"2019-07-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in MODX Revolution allows attackers to inject malicious scripts via user settings, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2018-20758/"}