{"answers":{"affected":"2 open source packages ship an affected version, including highcharts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20801 in the wild and no public exploit code.","fix":"Upgrade highcharts to 6.1.0 or later.","what":"CVE-2018-20801 is a high-severity denial of service vulnerability in n/a, published on 14 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20801 and fix it if it is affected.\n\nWhat it is: CVE-2018-20801 is a high-severity denial of service vulnerability in n/a, published on 14 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20801 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- highcharts (npm): affected all versions; fixed in 6.1.0\n- highcharts (npm): affected all versions; fixed in 6.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20801/ (Markdown: https://insights.sbomify.com/CVE-2018-20801/index.md)","id":"CVE-2018-20801","markdown":"https://insights.sbomify.com/CVE-2018-20801/index.md","name":"CVE-2018-20801","record":{"aliases":["GHSA-xmc8-cjfr-phx3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript charting library","requires_auth":"none","summary":"An attacker can cause a denial of service in the SVGRenderer component via ReDoS in Highcharts JS.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"highcharts","vendor":"highcharts"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-185","name":"Incorrect Regular Expression"}],"description":"In js/parts/SvgRenderer.js in Highcharts JS before 6.1.0, the use of backtracking regular expressions permitted an attacker to conduct a denial of service attack against the SVGRenderer component, aka ReDoS.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in highcharts","id":"CVE-2018-20801","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Post-auth queries on compound index may crash mongod","id":"CVE-2018-20802"},"packages":[{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":null,"source":"GHSA-xmc8-cjfr-phx3"},{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":"pkg:npm/highcharts","source":"GHSA-xmc8-cjfr-phx3"}],"prev":{"headline":"Other in n/a","id":"CVE-2018-20800"},"products":["n/a"],"published":"2019-03-14","related":[{"cvss_score":7.6,"headline":"Options structure open to XSS if passed unfiltered","id":"CVE-2021-29489","kev_date_added":null,"published":"2021-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in the SVGRenderer component via ReDoS in Highcharts JS.","url":"https://insights.sbomify.com/CVE-2018-20801/"}