# CVE-2018-20801: Regular Expression Denial of Service in highcharts

> An attacker can cause a denial of service in the SVGRenderer component via ReDoS in Highcharts JS.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xmc8-cjfr-phx3

## What is CVE-2018-20801?

CVE-2018-20801 is a high-severity denial of service vulnerability in n/a, published on 14 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In js/parts/SvgRenderer.js in Highcharts JS before 6.1.0, the use of backtracking regular expressions permitted an attacker to conduct a denial of service attack against the SVGRenderer component, aka ReDoS.

Weakness: CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2018-20801?

2 open source packages ship an affected version, including highcharts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `highcharts` | npm | All versions | 6.1.0 |
| `highcharts` | npm | All versions | 6.1.0 |

Products: Highcharts Highcharts.

## How do I fix CVE-2018-20801?

Upgrade highcharts to 6.1.0 or later.

## Is CVE-2018-20801 being exploited?

There is no known exploitation of CVE-2018-20801 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-29489](https://insights.sbomify.com/CVE-2021-29489/): Options structure open to XSS if passed unfiltered (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20801 and fix it if it is affected.

What it is: CVE-2018-20801 is a high-severity denial of service vulnerability in n/a, published on 14 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20801 in the wild and no public exploit code.

Affected packages and fixed versions:
- highcharts (npm): affected all versions; fixed in 6.1.0
- highcharts (npm): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20801/ (Markdown: https://insights.sbomify.com/CVE-2018-20801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20801
- OSV: https://osv.dev/vulnerability/CVE-2018-20801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20801/
Summaries are generated and may contain mistakes; the official description above is the record.
