# CVE-2018-20835: Improper Input Validation in tar-fs

> An attacker can overwrite arbitrary files on the system by crafting a malicious tarball with specific hardlink structures, affecting applications using the tar-fs library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x2mc-8fgj-3wmr

## What is CVE-2018-20835?

CVE-2018-20835 is a high-severity path traversal vulnerability in n/a, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in tar-fs before 1.16.2. An Arbitrary File Overwrite issue exists when extracting a tarball containing a hardlink to a file that already exists on the system, in conjunction with a later plain file with the same name as the hardlink. This plain file content replaces the existing file content.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-20835?

2 open source packages ship an affected version, including tar-fs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar-fs` | npm | All versions | 1.16.2 |
| `tar-fs` | npm | All versions | 1.16.2 |

Products: Tar-Fs Project Tar-Fs.

## How do I fix CVE-2018-20835?

Upgrade tar-fs to 1.16.2 or later.

## Is CVE-2018-20835 being exploited?

There is no known exploitation of CVE-2018-20835 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20835 and fix it if it is affected.

What it is: CVE-2018-20835 is a high-severity path traversal vulnerability in n/a, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20835 in the wild and no public exploit code.

Affected packages and fixed versions:
- tar-fs (npm): affected all versions; fixed in 1.16.2
- tar-fs (npm): affected all versions; fixed in 1.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20835/ (Markdown: https://insights.sbomify.com/CVE-2018-20835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20835
- OSV: https://osv.dev/vulnerability/CVE-2018-20835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20835/
Summaries are generated and may contain mistakes; the official description above is the record.
