{"answers":{"affected":"2 open source packages ship an affected version, including samlr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20857 in the wild and no public exploit code.","fix":"Upgrade samlr to 2.6.2 or later.","what":"CVE-2018-20857 is a high-severity vulnerability in n/a, published on 26 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20857 and fix it if it is affected.\n\nWhat it is: CVE-2018-20857 is a high-severity vulnerability in n/a, published on 26 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20857 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- samlr (RubyGems): affected all versions; fixed in 2.6.2\n- samlr (RubyGems): affected all versions; fixed in 2.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20857/ (Markdown: https://insights.sbomify.com/CVE-2018-20857/index.md)","id":"CVE-2018-20857","markdown":"https://insights.sbomify.com/CVE-2018-20857/index.md","name":"CVE-2018-20857","record":{"aliases":["GHSA-qpxp-5j56-gg3x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can exploit XML comment injection in Zendesk Samlr to bypass validation or access sensitive data.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"samlr","vendor":"zendesk"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Zendesk Samlr before 2.6.2 allows an XML nodes comment attack such as a name_id node with user@example.com followed by \u003c!----\u003e. and then the attacker's domain name.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"samlr XML nodes comment attack","id":"CVE-2018-20857","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in recommender-xblock","id":"CVE-2018-20858"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"samlr","purl":null,"source":"GHSA-qpxp-5j56-gg3x"},{"ecosystem":"RubyGems","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"samlr","purl":"pkg:gem/samlr","source":"GHSA-qpxp-5j56-gg3x"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2018-20856"},"products":["n/a"],"published":"2019-07-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit XML comment injection in Zendesk Samlr to bypass validation or access sensitive data.","url":"https://insights.sbomify.com/CVE-2018-20857/"}