{"answers":{"affected":"3 open source packages ship an affected version, including recommender-xblock. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20858 in the wild and no public exploit code.","fix":"Upgrade recommender-xblock to 1.3.1 or later.","what":"CVE-2018-20858 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-20858 and fix it if it is affected.\n\nWhat it is: CVE-2018-20858 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-20858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- recommender-xblock (PyPI): affected all versions; fixed in 1.3.1\n- recommender-xblock (PyPI): affected all versions; fixed in 1.3.1\n- recommender-xblock (PyPI): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20858/ (Markdown: https://insights.sbomify.com/CVE-2018-20858/index.md)","id":"CVE-2018-20858","markdown":"https://insights.sbomify.com/CVE-2018-20858/index.md","name":"CVE-2018-20858","record":{"aliases":["GHSA-3j5x-7ccf-ppgm","PYSEC-2019-219"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python recommender library","requires_auth":"none","summary":"Cross-site scripting vulnerability in the Recommender library allows attackers to inject malicious scripts into web pages viewed by other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"recommender","vendor":"edx"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Recommender before 2018-07-18 allows XSS.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in recommender-xblock","id":"CVE-2018-20858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-20859"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"recommender-xblock","purl":null,"source":"GHSA-3j5x-7ccf-ppgm"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"recommender-xblock","purl":"pkg:pypi/recommender-xblock","source":"GHSA-3j5x-7ccf-ppgm"},{"ecosystem":"PyPI","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"recommender-xblock","purl":"pkg:pypi/recommender-xblock","source":"PYSEC-2019-219"}],"prev":{"headline":"samlr XML nodes comment attack","id":"CVE-2018-20857"},"products":["n/a"],"published":"2019-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the Recommender library allows attackers to inject malicious scripts into web pages viewed by other users.","url":"https://insights.sbomify.com/CVE-2018-20858/"}