CVE-2018-20991 Double free in smallvec

Critical 9.8 Published Updated

A double free vulnerability in the smallvec Rust crate allows attackers to cause denial of service or potentially execute arbitrary code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-20991?

CVE-2018-20991 is a critical use after free vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in the smallvec crate before 0.6.3 for Rust. The Iterator implementation mishandles destructors, leading to a double free.

Weakness: CWE-415

Which versions are affected by CVE-2018-20991?

3 open source packages ship an affected version, including smallvec. It affects 1 product.

PackageAffectedFixed in
smallvec crates.ioFrom 0.3.20.3.4, 0.4.5, 0.5.1, 0.6.3
smallvec crates.ioFrom 0.3.20.6.3
smallvec crates.ioFrom 0.3.20.6.3
Linux distribution packages (1)
librsvg SUSE:Linux Enterprise Module for Package Hub 15 SP2All versions2.42.9-3.6.1

Products include Servo Smallvec.

How do I fix CVE-2018-20991?

Upgrade smallvec to a fixed version for your release line: 0.3.4, 0.4.5, 0.5.1 or 0.6.3.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2018-20991 being exploited?

There is no known exploitation of CVE-2018-20991 in the wild and no public exploit code.

Sources

Also known as GHSA-rxr4-x558-x7hw, RUSTSEC-2018-0003, SUSE-SU-2021:1310-1, UBUNTU-CVE-2018-20991.

Is CVE-2018-20991 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free