# CVE-2018-20993: Uncontrolled recursion in rust-yaml

> Attackers can cause a denial of service via uncontrolled recursion when deserializing malicious YAML data in the yaml-rust crate.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hv87-47h9-jcvq, RUSTSEC-2018-0006, UBUNTU-CVE-2018-20993

## What is CVE-2018-20993?

CVE-2018-20993 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the yaml-rust crate before 0.4.1 for Rust. There is uncontrolled recursion during deserialization.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2018-20993?

3 open source packages ship an affected version, including yaml-rust. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yaml-rust` | crates.io | All versions | 0.4.1 |
| `yaml-rust` | crates.io | All versions | 0.4.1 |
| `yaml-rust` | crates.io | From 0.0.0-0 | 0.4.1 |

Products: Yaml-Rust Project Yaml-Rust.

## How do I fix CVE-2018-20993?

Upgrade yaml-rust to 0.4.1 or later.

## Is CVE-2018-20993 being exploited?

There is no known exploitation of CVE-2018-20993 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1010182](https://insights.sbomify.com/CVE-2019-1010182/): Denial of service in yaml-rust (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20993 and fix it if it is affected.

What it is: CVE-2018-20993 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20993 in the wild and no public exploit code.

Affected packages and fixed versions:
- yaml-rust (crates.io): affected all versions; fixed in 0.4.1
- yaml-rust (crates.io): affected all versions; fixed in 0.4.1
- yaml-rust (crates.io): affected from 0.0.0-0; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20993/ (Markdown: https://insights.sbomify.com/CVE-2018-20993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20993
- OSV: https://osv.dev/vulnerability/CVE-2018-20993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20993/
Summaries are generated and may contain mistakes; the official description above is the record.
