# CVE-2018-20995: Memory corruption slice-deque

> Attackers can trigger memory corruption in the slice-deque Rust library, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hr3c-6mmp-6m39, RUSTSEC-2018-0008

## What is CVE-2018-20995?

CVE-2018-20995 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the slice-deque crate before 0.1.16 for Rust. move_head_unchecked allows memory corruption because deque updates are mishandled.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2018-20995?

3 open source packages ship an affected version, including slice-deque. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slice-deque` | crates.io | All versions | 0.1.16 |
| `slice-deque` | crates.io | All versions | 0.1.16 |
| `slice-deque` | crates.io | From 0.0.0-0 | 0.1.16 |

Products: Slice-Deque Project Slice-Deque.

## How do I fix CVE-2018-20995?

Upgrade slice-deque to 0.1.16 or later.

## Is CVE-2018-20995 being exploited?

There is no known exploitation of CVE-2018-20995 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-15543](https://insights.sbomify.com/CVE-2019-15543/): Out of bounds write in slice-deque (critical 9.8)
- [CVE-2021-29938](https://insights.sbomify.com/CVE-2021-29938/): Double free in slice-deque (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20995 and fix it if it is affected.

What it is: CVE-2018-20995 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20995 in the wild and no public exploit code.

Affected packages and fixed versions:
- slice-deque (crates.io): affected all versions; fixed in 0.1.16
- slice-deque (crates.io): affected all versions; fixed in 0.1.16
- slice-deque (crates.io): affected from 0.0.0-0; fixed in 0.1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20995/ (Markdown: https://insights.sbomify.com/CVE-2018-20995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20995
- OSV: https://osv.dev/vulnerability/CVE-2018-20995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20995/
Summaries are generated and may contain mistakes; the official description above is the record.
