# CVE-2018-20996: Double free in crossbeam

> A double free vulnerability in the crossbeam Rust library allows attackers to cause denial of service or potentially execute arbitrary code.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c3cw-c387-pj65, RUSTSEC-2018-0009, UBUNTU-CVE-2018-20996

## What is CVE-2018-20996?

CVE-2018-20996 is a critical use after free vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the crossbeam crate before 0.4.1 for Rust. There is a double free because of destructor mishandling.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2018-20996?

3 open source packages ship an affected version, including crossbeam. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crossbeam` | crates.io | From 0.4.0 | 0.4.1 |
| `crossbeam` | crates.io | From 0.4.0 | 0.4.1 |
| `crossbeam` | crates.io | From 0.4.0 | 0.4.1 |

Products: Crossbeam Project Crossbeam.

## How do I fix CVE-2018-20996?

Upgrade crossbeam to 0.4.1 or later.

## Is CVE-2018-20996 being exploited?

There is no known exploitation of CVE-2018-20996 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32810](https://insights.sbomify.com/CVE-2021-32810/): Data race in crossbeam-deque (critical 9.8)
- [CVE-2022-23639](https://insights.sbomify.com/CVE-2022-23639/): Improper Restriction of Operations within the Bounds of a Memory Buffer and Race Condition in crossbeam-utils (high 8.1)
- [CVE-2020-15254](https://insights.sbomify.com/CVE-2020-15254/): Undefined Behavior in bounded Crossbeam channel (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20996 and fix it if it is affected.

What it is: CVE-2018-20996 is a critical use after free vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20996 in the wild and no public exploit code.

Affected packages and fixed versions:
- crossbeam (crates.io): affected from 0.4.0; fixed in 0.4.1
- crossbeam (crates.io): affected from 0.4.0; fixed in 0.4.1
- crossbeam (crates.io): affected from 0.4.0; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20996/ (Markdown: https://insights.sbomify.com/CVE-2018-20996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20996
- OSV: https://osv.dev/vulnerability/CVE-2018-20996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20996/
Summaries are generated and may contain mistakes; the official description above is the record.
