# CVE-2018-20997: Use after free in openssl

> A use-after-free vulnerability in the Rust openssl crate allows attackers to potentially execute arbitrary code or cause a denial of service during CMS signing operations.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xjxc-vfw2-cg96, RUSTSEC-2018-0010

## What is CVE-2018-20997?

CVE-2018-20997 is a critical use after free vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the openssl crate before 0.10.9 for Rust. A use-after-free occurs in CMS Signing.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2018-20997?

3 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.10.8 | 0.10.9 |
| `openssl` | crates.io | From 0.10.8 | 0.10.9 |
| `openssl` | crates.io | From 0.10.8 | 0.10.9 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2018-20997?

Upgrade openssl to 0.10.9 or later.

## Is CVE-2018-20997 being exploited?

There is no known exploitation of CVE-2018-20997 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-41898](https://insights.sbomify.com/CVE-2026-41898/): rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer (high 8.3)
- [CVE-2026-41681](https://insights.sbomify.com/CVE-2026-41681/): rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check (high 8.1)
- [CVE-2016-10931](https://insights.sbomify.com/CVE-2016-10931/): Improper Certificate Validation in openssl (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)
- [CVE-2026-41678](https://insights.sbomify.com/CVE-2026-41678/): rust-openssl: Incorrect bounds assertion in aes key wrap (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20997 and fix it if it is affected.

What it is: CVE-2018-20997 is a critical use after free vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20997 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.10.8; fixed in 0.10.9
- openssl (crates.io): affected from 0.10.8; fixed in 0.10.9
- openssl (crates.io): affected from 0.10.8; fixed in 0.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20997/ (Markdown: https://insights.sbomify.com/CVE-2018-20997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20997
- OSV: https://osv.dev/vulnerability/CVE-2018-20997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20997/
Summaries are generated and may contain mistakes; the official description above is the record.
