{"answers":{"affected":"5 open source packages ship an affected version, including arrayfire. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20998 in the wild and no public exploit code.","fix":"Upgrade arrayfire to 3.6.0 or later.","what":"CVE-2018-20998 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20998 and fix it if it is affected.\n\nWhat it is: CVE-2018-20998 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20998 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- arrayfire (PyPI): affected all versions; fixed in 3.6.0\n- arrayfire (PyPI): affected all versions; fixed in 3.6.0\n- arrayfire (crates.io): affected all versions; fixed in 3.6.0\n- arrayfire (crates.io): affected all versions; fixed in 3.6.0\n- arrayfire (crates.io): affected from 0.0.0-0; fixed in 3.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20998/ (Markdown: https://insights.sbomify.com/CVE-2018-20998/index.md)","id":"CVE-2018-20998","markdown":"https://insights.sbomify.com/CVE-2018-20998/index.md","name":"CVE-2018-20998","record":{"aliases":["GHSA-69fv-gw6g-8ccg","RUSTSEC-2018-0011"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust arrayfire crate","requires_auth":"none","summary":"Memory corruption in the arrayfire Rust crate allows attackers to potentially execute arbitrary code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"arrayfire","vendor":"arrayfire"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.","ecosystems":["PyPI","crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential memory corruption in arrayfire","id":"CVE-2018-20998","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2018"},"n_packages":5,"n_references":1,"next":{"headline":"Flaw in streaming state in orion","id":"CVE-2018-20999"},"packages":[{"ecosystem":"PyPI","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"arrayfire","purl":null,"source":"GHSA-69fv-gw6g-8ccg"},{"ecosystem":"PyPI","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"arrayfire","purl":"pkg:pypi/arrayfire","source":"GHSA-69fv-gw6g-8ccg"},{"ecosystem":"crates.io","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"arrayfire","purl":null,"source":"GHSA-69fv-gw6g-8ccg"},{"ecosystem":"crates.io","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"arrayfire","purl":"pkg:cargo/arrayfire","source":"GHSA-69fv-gw6g-8ccg"},{"ecosystem":"crates.io","fixed":["3.6.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"arrayfire","purl":"pkg:cargo/arrayfire","source":"RUSTSEC-2018-0011"}],"prev":{"headline":"Use after free in openssl","id":"CVE-2018-20997"},"products":["n/a"],"published":"2019-08-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Memory corruption in the arrayfire Rust crate allows attackers to potentially execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2018-20998/"}