# CVE-2018-21030: Cross-site scripting in Jupyter Notebook

> An attacker can execute arbitrary scripts via XSS in SVG documents due to missing CSP headers in Jupyter Notebook.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-21030, GHSA-jqwc-jm56-wcwj, PYSEC-2019-157, UBUNTU-CVE-2018-21030

## What is CVE-2018-21030?

CVE-2018-21030 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jupyter Notebook before 5.5.0 does not use a CSP header to treat served files as belonging to a separate origin. Thus, for example, an XSS payload can be placed in an SVG document.

Weakness: CWE-863 (Incorrect Authorization), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-21030?

3 open source packages ship an affected version, including notebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `notebook` | PyPI | All versions | 5.5.0 |
| `notebook` | PyPI | All versions | 5.5.0rc1 |
| `notebook` | PyPI | All versions | 5.5.0rc1 |

Products: Jupyter Notebook.

## How do I fix CVE-2018-21030?

Upgrade notebook to a fixed version for your release line: 5.5.0 or 5.5.0rc1.

## Is CVE-2018-21030 being exploited?

There is no known exploitation of CVE-2018-21030 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32798](https://insights.sbomify.com/CVE-2021-32798/): Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook (critical 10.0)
- [CVE-2018-8768](https://insights.sbomify.com/CVE-2018-8768/): Jupyter Notebook file bypasses sanitization, executes JavaScript (high 7.8)
- [CVE-2022-24758](https://insights.sbomify.com/CVE-2022-24758/): Insertion of Sensitive Information into Log File affects Jupyter Notebook (high 7.5)
- [CVE-2019-10856](https://insights.sbomify.com/CVE-2019-10856/): Jupyter Notebook open redirect vulnerability (medium 6.1)
- [CVE-2018-19351](https://insights.sbomify.com/CVE-2018-19351/): Jupyter Notebook XSS via untrusted notebooks (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-21030 and fix it if it is affected.

What it is: CVE-2018-21030 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-21030 in the wild and no public exploit code.

Affected packages and fixed versions:
- notebook (PyPI): affected all versions; fixed in 5.5.0
- notebook (PyPI): affected all versions; fixed in 5.5.0rc1
- notebook (PyPI): affected all versions; fixed in 5.5.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-21030/ (Markdown: https://insights.sbomify.com/CVE-2018-21030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-21030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-21030
- OSV: https://osv.dev/vulnerability/CVE-2018-21030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-21030/
Summaries are generated and may contain mistakes; the official description above is the record.
