# CVE-2018-21036: Improper Input Validation in sails-hook-sockets

> Attackers can cause a denial of service in Sails.js applications by sending a WebSocket request with an empty pathname due to missing error handling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f7f4-hqp2-7prc

## What is CVE-2018-21036?

CVE-2018-21036 is a high-severity denial of service vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sails.js before v1.0.0-46 allows attackers to cause a denial of service with a single request because there is no error handler in sails-hook-sockets to handle an empty pathname in a WebSocket request.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-21036?

2 open source packages ship an affected version, including sails-hook-sockets. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sails-hook-sockets` | npm | All versions | 1.5.5 |
| `sails-hook-sockets` | npm | All versions | 1.5.5 |

Products: Sailsjs Sails.

## How do I fix CVE-2018-21036?

Upgrade sails-hook-sockets to 1.5.5 or later.

## Is CVE-2018-21036 being exploited?

There is no known exploitation of CVE-2018-21036 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-44908](https://insights.sbomify.com/CVE-2021-44908/): Prototype Pollution in Sails.js (critical 9.8)
- [CVE-2023-38504](https://insights.sbomify.com/CVE-2023-38504/): Sails DoS vulnerability for apps with sockets enabled (high 7.5)
- [CVE-2016-10549](https://insights.sbomify.com/CVE-2016-10549/): Sails before 0.12.7 vulnerable to Broken CORS (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-21036 and fix it if it is affected.

What it is: CVE-2018-21036 is a high-severity denial of service vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-21036 in the wild and no public exploit code.

Affected packages and fixed versions:
- sails-hook-sockets (npm): affected all versions; fixed in 1.5.5
- sails-hook-sockets (npm): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-21036/ (Markdown: https://insights.sbomify.com/CVE-2018-21036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-21036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-21036
- OSV: https://osv.dev/vulnerability/CVE-2018-21036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-21036/
Summaries are generated and may contain mistakes; the official description above is the record.
