# CVE-2018-21234: Deserialization of Untrusted Data in Jodd

> Attackers can execute arbitrary code via deserialization of untrusted JSON data in Jodd when specific metadata settings are enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jrg3-qq99-35g7, UBUNTU-CVE-2018-21234

## What is CVE-2018-21234?

CVE-2018-21234 is a critical unsafe deserialization vulnerability in n/a, published on 21 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jodd before 5.0.4 performs Deserialization of Untrusted JSON Data when setClassMetadataName is set.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-21234?

2 open source packages ship an affected version, including org.jodd:jodd-json. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jodd:jodd-json` | Maven | All versions | 5.0.4 |
| `org.jodd:jodd-json` | Maven | All versions | 5.0.4 |

Products: Apache Hive, Jodd Jodd.

## How do I fix CVE-2018-21234?

Upgrade org.jodd:jodd-json to 5.0.4 or later.

## Is CVE-2018-21234 being exploited?

There is no known exploitation of CVE-2018-21234 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)
- [CVE-2015-7521](https://insights.sbomify.com/CVE-2015-7521/): High severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-21234 and fix it if it is affected.

What it is: CVE-2018-21234 is a critical unsafe deserialization vulnerability in n/a, published on 21 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-21234 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jodd:jodd-json (Maven): affected all versions; fixed in 5.0.4
- org.jodd:jodd-json (Maven): affected all versions; fixed in 5.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-21234/ (Markdown: https://insights.sbomify.com/CVE-2018-21234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-21234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-21234
- OSV: https://osv.dev/vulnerability/CVE-2018-21234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-21234/
Summaries are generated and may contain mistakes; the official description above is the record.
