# CVE-2018-21246: Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication

> Attackers can bypass TLS client authentication in Caddy web server due to missing strict host matching, allowing unauthorized access.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gr7w-x2jp-3xgw, GO-2020-0043

## What is CVE-2018-21246?

CVE-2018-21246 is a critical authentication bypass vulnerability in n/a, published on 15 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy before 0.10.13 mishandles TLS client authentication, as demonstrated by an authentication bypass caused by the lack of the StrictHostMatching mode.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-21246?

3 open source packages ship an affected version, including github.com/caddyserver/caddy and github.com/mholt/caddy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy` | Go | All versions | 0.10.13 |
| `github.com/caddyserver/caddy` | Go | All versions | 0.10.13 |
| `github.com/mholt/caddy` | Go | All versions | 0.10.13 |

Products: Caddyserver Caddy.

## How do I fix CVE-2018-21246?

Upgrade github.com/caddyserver/caddy to 0.10.13 or later.

## Is CVE-2018-21246 being exploited?

There is no known exploitation of CVE-2018-21246 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)
- [CVE-2026-30851](https://insights.sbomify.com/CVE-2026-30851/): Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-21246 and fix it if it is affected.

What it is: CVE-2018-21246 is a critical authentication bypass vulnerability in n/a, published on 15 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-21246 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 0.10.13
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 0.10.13
- github.com/mholt/caddy (Go): affected all versions; fixed in 0.10.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-21246/ (Markdown: https://insights.sbomify.com/CVE-2018-21246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-21246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-21246
- OSV: https://osv.dev/vulnerability/CVE-2018-21246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-21246/
Summaries are generated and may contain mistakes; the official description above is the record.
