# CVE-2018-21270: Out-of-bounds Read in stringstream

> An out-of-bounds read in the stringstream module allows attackers to read uninitialized memory when processing numeric input streams.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2020
- **Updated:** 5 Aug 2024
- **Also known as:** CLSA-2026-1772583200, CLSA-2026-1773274557, DEBIAN-CVE-2018-21270, GHSA-mf6x-7mm4-x2g7, UBUNTU-CVE-2018-21270

## What is CVE-2018-21270?

CVE-2018-21270 is a medium-severity vulnerability in Nodejs Node.js, published on 3 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an out-of-bounds read because of allocation of uninitialized buffers when a number is passed in the input stream (when using Node.js 4.x).

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2018-21270?

2 open source packages ship an affected version, including stringstream. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stringstream` | npm | All versions | 0.0.6 |
| `stringstream` | npm | All versions | 0.0.6 |

Products: Nodejs Node.js.

## How do I fix CVE-2018-21270?

Upgrade stringstream to 0.0.6 or later.

## Is CVE-2018-21270 being exploited?

There is no known exploitation of CVE-2018-21270 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-21270 and fix it if it is affected.

What it is: CVE-2018-21270 is a medium-severity vulnerability in Nodejs Node.js, published on 3 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-21270 in the wild and no public exploit code.

Affected packages and fixed versions:
- stringstream (npm): affected all versions; fixed in 0.0.6
- stringstream (npm): affected all versions; fixed in 0.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-21270/ (Markdown: https://insights.sbomify.com/CVE-2018-21270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-21270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-21270
- OSV: https://osv.dev/vulnerability/CVE-2018-21270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-21270/
Summaries are generated and may contain mistakes; the official description above is the record.
