# CVE-2018-25013: Memory corruption in libwebp

> A heap-based buffer overflow in libwebp allows attackers to execute arbitrary code or cause denial of service via crafted images.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2021
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-25013, GHSA-xj9f-6qqc-cpfp, UBUNTU-CVE-2018-25013

## What is CVE-2018-25013?

CVE-2018-25013 is a critical memory corruption vulnerability in Redhat Enterprise Linux, published on 21 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A heap-based buffer overflow was found in libwebp in versions before 1.0.1 in ShiftBytes().

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2018-25013?

It affects 2 products.


Products: Redhat Enterprise Linux, Webmproject Libwebp.

## How do I fix CVE-2018-25013?

Upgrade to a fixed version.

## Is CVE-2018-25013 being exploited?

There is no known exploitation of CVE-2018-25013 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2018-14667](https://insights.sbomify.com/CVE-2018-14667/): Red Hat JBoss RichFaces Framework Expression Language Injection (critical 9.8, exploited in the wild)
- [CVE-2021-20325](https://insights.sbomify.com/CVE-2021-20325/): Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit (critical 9.8)
- [CVE-2018-25011](https://insights.sbomify.com/CVE-2018-25011/): Memory corruption in libwebp (critical 9.8)
- [CVE-2018-25014](https://insights.sbomify.com/CVE-2018-25014/): Other in libwebp (critical 9.8)
- [CVE-2014-3585](https://insights.sbomify.com/CVE-2014-3585/): Supply chain in redhat-upgrade-tool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25013 and fix it if it is affected.

What it is: CVE-2018-25013 is a critical memory corruption vulnerability in Redhat Enterprise Linux, published on 21 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25013 in the wild and no public exploit code.

Affected product: Redhat Enterprise Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25013/ (Markdown: https://insights.sbomify.com/CVE-2018-25013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25013
- OSV: https://osv.dev/vulnerability/CVE-2018-25013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25013/
Summaries are generated and may contain mistakes; the official description above is the record.
