# CVE-2018-25045: Django REST framework XSS Vulnerability

> Cross-site scripting vulnerability in Django REST framework allows attackers to execute arbitrary scripts via the Browsable API.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2022
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-25045, GHSA-xqcf-hj92-967m, PYSEC-2026-804, UBUNTU-CVE-2018-25045

## What is CVE-2018-25045?

CVE-2018-25045 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Django REST framework (aka django-rest-framework) before 3.9.1 allows XSS because the default DRF Browsable API view templates disable autoescaping.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-25045?

3 open source packages ship an affected version, including django-rest-framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-rest-framework` | PyPI | All versions | 3.9.1 |
| `django-rest-framework` | PyPI | All versions | 3.9.1 |
| `django-rest-framework` | PyPI | All versions | 3.9.1 |

Products: Django-Rest-Framework Django Rest Framework.

## How do I fix CVE-2018-25045?

Upgrade django-rest-framework to 3.9.1 or later.

## Is CVE-2018-25045 being exploited?

There is no known exploitation of CVE-2018-25045 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25045 and fix it if it is affected.

What it is: CVE-2018-25045 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-25045 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-rest-framework (PyPI): affected all versions; fixed in 3.9.1
- django-rest-framework (PyPI): affected all versions; fixed in 3.9.1
- django-rest-framework (PyPI): affected all versions; fixed in 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25045/ (Markdown: https://insights.sbomify.com/CVE-2018-25045/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25045
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25045
- OSV: https://osv.dev/vulnerability/CVE-2018-25045

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25045/
Summaries are generated and may contain mistakes; the official description above is the record.
