CVE-2018-25047 Smarty Cross-site Scripting vulnerability in pages that use smarty_function_mailto
Cross-site scripting vulnerability in Smarty allows attackers to inject JavaScript via parameterized mailto function calls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-25047?
CVE-2018-25047 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
Weakness: CWE-79
Which versions are affected by CVE-2018-25047?
4 open source packages ship an affected version, including smarty/smarty. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
smarty/smarty Packagist | All versions | 3.1.47 |
smarty/smarty Packagist | All versions | 3.1.47 |
smarty/smarty Packagist | From 4.0.0 | 4.2.1 |
smarty/smarty Packagist | From 4.0.0 | 4.2.1 |
Products include Debian Debian Linux, Smarty Smarty.
How do I fix CVE-2018-25047?
Upgrade smarty/smarty to a fixed version for your release line: 3.1.47 or 4.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-25047 being exploited?
There is no known exploitation of CVE-2018-25047 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-25047, DLA-3262-1, GHSA-hwq7-5vv9-c6cf, MGASA-2023-0014, UBUNTU-CVE-2018-25047.