# CVE-2018-25047: Smarty Cross-site Scripting vulnerability in pages that use smarty_function_mailto

> Cross-site scripting vulnerability in Smarty allows attackers to inject JavaScript via parameterized mailto function calls.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2018-25047, DLA-3262-1, GHSA-hwq7-5vv9-c6cf, MGASA-2023-0014, UBUNTU-CVE-2018-25047

## What is CVE-2018-25047?

CVE-2018-25047 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-25047?

4 open source packages ship an affected version, including smarty/smarty. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 3.1.47 |
| `smarty/smarty` | Packagist | All versions | 3.1.47 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.2.1 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.2.1 |

Products: Debian Debian Linux, Smarty Smarty.

## How do I fix CVE-2018-25047?

Upgrade smarty/smarty to a fixed version for your release line: 3.1.47 or 4.2.1.

## Is CVE-2018-25047 being exploited?

There is no known exploitation of CVE-2018-25047 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25047 and fix it if it is affected.

What it is: CVE-2018-25047 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-25047 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.47
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.47
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.2.1
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25047/ (Markdown: https://insights.sbomify.com/CVE-2018-25047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25047
- OSV: https://osv.dev/vulnerability/CVE-2018-25047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25047/
Summaries are generated and may contain mistakes; the official description above is the record.
