{"answers":{"affected":"2 open source packages ship an affected version, including harvesthq/chosen. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25050 in the wild and no public exploit code.","fix":"Upgrade harvesthq/chosen to 1.8.7 or later.","what":"CVE-2018-25050 is a low-severity cross-site scripting vulnerability in Harvest Chosen, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-25050 and fix it if it is affected.\n\nWhat it is: CVE-2018-25050 is a low-severity cross-site scripting vulnerability in Harvest Chosen, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-25050 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- harvesthq/chosen (Packagist): affected all versions; fixed in 1.8.7\n- harvesthq/chosen (Packagist): affected all versions; fixed in 1.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25050/ (Markdown: https://insights.sbomify.com/CVE-2018-25050/index.md)","id":"CVE-2018-25050","markdown":"https://insights.sbomify.com/CVE-2018-25050/index.md","name":"CVE-2018-25050","record":{"aliases":["GHSA-x5q4-m45m-fm94","UBUNTU-CVE-2018-25050"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Chosen JavaScript library","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via the group_label argument in Harvest Chosen, potentially executing code in the victim's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"chosen","vendor":"getharvest"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Harvest Chosen abstract-chosen.coffee AbstractChosen cross site scripting","id":"CVE-2018-25050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":5,"next":{"headline":"JmPotato Pomash editor.html cross site scripting","id":"CVE-2018-25051"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.7"],"introduced":["0"],"last_affected":[],"package":"harvesthq/chosen","purl":null,"source":"GHSA-x5q4-m45m-fm94"},{"ecosystem":"Packagist","fixed":["1.8.7"],"introduced":["0"],"last_affected":[],"package":"harvesthq/chosen","purl":"pkg:composer/harvesthq/chosen","source":"GHSA-x5q4-m45m-fm94"}],"prev":{"headline":"email-existence index.js redos","id":"CVE-2018-25049"},"products":["Chosen"],"published":"2022-12-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["Harvest"]},"summary":"An attacker can inject malicious scripts via the group_label argument in Harvest Chosen, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2018-25050/"}