# CVE-2018-25050: Harvest Chosen abstract-chosen.coffee AbstractChosen cross site scripting

> An attacker can inject malicious scripts via the group_label argument in Harvest Chosen, potentially executing code in the victim's browser.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-x5q4-m45m-fm94, UBUNTU-CVE-2018-25050

## What is CVE-2018-25050?

CVE-2018-25050 is a low-severity cross-site scripting vulnerability in Harvest Chosen, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-25050?

2 open source packages ship an affected version, including harvesthq/chosen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `harvesthq/chosen` | Packagist | All versions | 1.8.7 |
| `harvesthq/chosen` | Packagist | All versions | 1.8.7 |

Products: Getharvest Chosen.

## How do I fix CVE-2018-25050?

Upgrade harvesthq/chosen to 1.8.7 or later.

## Is CVE-2018-25050 being exploited?

There is no known exploitation of CVE-2018-25050 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25050 and fix it if it is affected.

What it is: CVE-2018-25050 is a low-severity cross-site scripting vulnerability in Harvest Chosen, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-25050 in the wild and no public exploit code.

Affected packages and fixed versions:
- harvesthq/chosen (Packagist): affected all versions; fixed in 1.8.7
- harvesthq/chosen (Packagist): affected all versions; fixed in 1.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25050/ (Markdown: https://insights.sbomify.com/CVE-2018-25050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25050
- OSV: https://osv.dev/vulnerability/CVE-2018-25050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25050/
Summaries are generated and may contain mistakes; the official description above is the record.
