{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25052 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-25052 is a low-severity cross-site scripting vulnerability in Catalyst-Plugin-Session, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-25052 and fix it if it is affected.\n\nWhat it is: CVE-2018-25052 is a low-severity cross-site scripting vulnerability in Catalyst-Plugin-Session, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-25052 in the wild and no public exploit code.\n\nAffected product: Catalyst-Plugin-Session. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25052/ (Markdown: https://insights.sbomify.com/CVE-2018-25052/index.md)","id":"CVE-2018-25052","markdown":"https://insights.sbomify.com/CVE-2018-25052/index.md","name":"CVE-2018-25052","record":{"aliases":["DEBIAN-CVE-2018-25052","GHSA-6647-v6q5-pgfg","UBUNTU-CVE-2018-25052"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl Catalyst plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the Catalyst-Plugin-Session library allows remote attackers to inject malicious scripts via the session ID argument.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"catalyst-plugin-session","vendor":"catalyst-plugin-session_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Catalyst-Plugin-Session Session ID Session.pm _load_sessionid cross site scripting","id":"CVE-2018-25052","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2018"},"n_packages":0,"n_references":4,"next":{"headline":"moappi Json2html json2html.js cross site scripting","id":"CVE-2018-25053"},"packages":[],"prev":{"headline":"JmPotato Pomash editor.html cross site scripting","id":"CVE-2018-25051"},"products":["Catalyst-Plugin-Session"],"published":"2022-12-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A cross-site scripting vulnerability in the Catalyst-Plugin-Session library allows remote attackers to inject malicious scripts via the session ID argument.","url":"https://insights.sbomify.com/CVE-2018-25052/"}