# CVE-2018-25052: Catalyst-Plugin-Session Session ID Session.pm _load_sessionid cross site scripting

> A cross-site scripting vulnerability in the Catalyst-Plugin-Session library allows remote attackers to inject malicious scripts via the session ID argument.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-25052, GHSA-6647-v6q5-pgfg, UBUNTU-CVE-2018-25052

## What is CVE-2018-25052?

CVE-2018-25052 is a low-severity cross-site scripting vulnerability in Catalyst-Plugin-Session, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-25052?

It affects 1 product.


Products: Catalyst-Plugin-Session Project Catalyst-Plugin-Session.

## How do I fix CVE-2018-25052?

Upgrade to a fixed version.

## Is CVE-2018-25052 being exploited?

There is no known exploitation of CVE-2018-25052 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25052 and fix it if it is affected.

What it is: CVE-2018-25052 is a low-severity cross-site scripting vulnerability in Catalyst-Plugin-Session, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-25052 in the wild and no public exploit code.

Affected product: Catalyst-Plugin-Session. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25052/ (Markdown: https://insights.sbomify.com/CVE-2018-25052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25052
- OSV: https://osv.dev/vulnerability/CVE-2018-25052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25052/
Summaries are generated and may contain mistakes; the official description above is the record.
