CVE-2018-25053 moappi Json2html json2html.js cross site scripting

Medium 4.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2018-25053?

CVE-2018-25053 is a medium-severity vulnerability in moappi Json2html, published on 28 Dec 2022.

Official description

A vulnerability was found in moappi Json2html up to 1.1.x and classified as problematic. This issue affects some unknown processing of the file json2html.js. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.2.0 is able to address this issue. The name of the patch is 2d3d24d971b19a8ed1fb823596300b9835d55801. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216959.

Weakness: CWE-79

Which versions are affected by CVE-2018-25053?

2 open source packages ship an affected version, including node-json2html. It affects 1 product.

PackageAffectedFixed in
node-json2html npmAll versions1.2.0
node-json2html npmAll versions1.2.0

Products include Json2html Json2html.

How do I fix CVE-2018-25053?

Upgrade node-json2html to 1.2.0 or later.

Is CVE-2018-25053 being exploited?

There is no known exploitation of CVE-2018-25053 in the wild and no public exploit code.

Sources

Also known as GHSA-79mp-cxp4-9p6r.

Is CVE-2018-25053 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free