CVE-2018-25055 FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting

Low 3.5 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2018-25055?

CVE-2018-25055 is a low-severity vulnerability in FarCry Solr Pro Plugin, published on 28 Dec 2022.

Official description

A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2018-25055?

It affects 1 product.

Products include Farcry Solr Pro Project Farcry Solr Pro.

How do I fix CVE-2018-25055?

No fix has been published for CVE-2018-25055 yet. Limit exposure of the affected software until one is available.

Is CVE-2018-25055 being exploited?

There is no known exploitation of CVE-2018-25055 in the wild and no public exploit code.

Sources

Also known as GHSA-2gpx-vh9j-9x8j.

Is CVE-2018-25055 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free