{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25055 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-25055 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-25055 is a low-severity vulnerability in FarCry Solr Pro Plugin, published on 28 Dec 2022."},"fix_prompt":"Check this codebase for CVE-2018-25055 and fix it if it is affected.\n\nWhat it is: CVE-2018-25055 is a low-severity vulnerability in FarCry Solr Pro Plugin, published on 28 Dec 2022. \nExploitation: There is no known exploitation of CVE-2018-25055 in the wild and no public exploit code.\n\nAffected product: FarCry Solr Pro Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25055/ (Markdown: https://insights.sbomify.com/CVE-2018-25055/index.md)","id":"CVE-2018-25055","markdown":"https://insights.sbomify.com/CVE-2018-25055/index.md","name":"CVE-2018-25055","record":{"aliases":["GHSA-2gpx-vh9j-9x8j"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"farcry_solr_pro","vendor":"farcry_solr_pro_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting","id":"CVE-2018-25055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2018"},"n_packages":0,"n_references":5,"next":{"headline":"yolapi metadata.py render_description cross site scripting","id":"CVE-2018-25056"},"packages":[],"prev":{"headline":"shred cilla Search search.jsp cross site scripting","id":"CVE-2018-25054"},"products":["FarCry Solr Pro Plugin"],"published":"2022-12-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2018-25055/"}