# CVE-2018-25055: FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2gpx-vh9j-9x8j

## What is CVE-2018-25055?

CVE-2018-25055 is a low-severity vulnerability in FarCry Solr Pro Plugin, published on 28 Dec 2022. 

### Official description

A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-25055?

It affects 1 product.


Products: Farcry Solr Pro Project Farcry Solr Pro.

## How do I fix CVE-2018-25055?

No fix has been published for CVE-2018-25055 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-25055 being exploited?

There is no known exploitation of CVE-2018-25055 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25055 and fix it if it is affected.

What it is: CVE-2018-25055 is a low-severity vulnerability in FarCry Solr Pro Plugin, published on 28 Dec 2022. 
Exploitation: There is no known exploitation of CVE-2018-25055 in the wild and no public exploit code.

Affected product: FarCry Solr Pro Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25055/ (Markdown: https://insights.sbomify.com/CVE-2018-25055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25055
- OSV: https://osv.dev/vulnerability/CVE-2018-25055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25055/
Summaries are generated and may contain mistakes; the official description above is the record.
