{"answers":{"affected":"2 open source packages ship an affected version, including twitter-fetcher-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25058 in the wild and no public exploit code.","fix":"Upgrade twitter-fetcher-js to 18.0.0 or later.","what":"CVE-2018-25058 is a medium-severity vulnerability in Twitter-Post-Fetcher, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-25058 and fix it if it is affected.\n\nWhat it is: CVE-2018-25058 is a medium-severity vulnerability in Twitter-Post-Fetcher, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-25058 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- twitter-fetcher-js (npm): affected all versions; fixed in 18.0.0\n- twitter-fetcher-js (npm): affected all versions; fixed in 18.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25058/ (Markdown: https://insights.sbomify.com/CVE-2018-25058/index.md)","id":"CVE-2018-25058","markdown":"https://insights.sbomify.com/CVE-2018-25058/index.md","name":"CVE-2018-25058","record":{"aliases":["GHSA-m688-cx2p-rgq9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Twitter Post Fetcher","requires_auth":"none","summary":"Attackers can exploit reverse tabnabbing in Twitter-Post-Fetcher to redirect users to malicious sites via untrusted link targets.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"twitter-post-fetcher","vendor":"twitter-post-fetcher_project"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-1022","name":"Use of Web Link to Untrusted Target with window.opener Access"}],"description":"A vulnerability classified as problematic has been found in Twitter-Post-Fetcher up to 17.x. This affects an unknown part of the file js/twitterFetcher.js of the component Link Target Handler. The manipulation leads to use of web link to untrusted target with window.opener access. It is possible to initiate the attack remotely. Upgrading to version 18.0.0 is able to address this issue. The name of the patch is 7d281c6fb5acbc29a2cad295262c1f0c19ca56f3. It is recommended to upgrade the affected component. The identifier VDB-217017 was assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Twitter-Post-Fetcher Link Target twitterFetcher.js reverse tabnabbing","id":"CVE-2018-25058","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2018"},"n_packages":2,"n_references":5,"next":{"headline":"pastebinit server.go pasteHandler path traversal","id":"CVE-2018-25059"},"packages":[{"ecosystem":"npm","fixed":["18.0.0"],"introduced":["0"],"last_affected":[],"package":"twitter-fetcher-js","purl":null,"source":"GHSA-m688-cx2p-rgq9"},{"ecosystem":"npm","fixed":["18.0.0"],"introduced":["0"],"last_affected":[],"package":"twitter-fetcher-js","purl":"pkg:npm/twitter-fetcher-js","source":"GHSA-m688-cx2p-rgq9"}],"prev":{"headline":"simple_php_link_shortener index.php sql injection","id":"CVE-2018-25057"},"products":["Twitter-Post-Fetcher"],"published":"2022-12-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit reverse tabnabbing in Twitter-Post-Fetcher to redirect users to malicious sites via untrusted link targets.","url":"https://insights.sbomify.com/CVE-2018-25058/"}