# CVE-2018-25058: Twitter-Post-Fetcher Link Target twitterFetcher.js reverse tabnabbing

> Attackers can exploit reverse tabnabbing in Twitter-Post-Fetcher to redirect users to malicious sites via untrusted link targets.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m688-cx2p-rgq9

## What is CVE-2018-25058?

CVE-2018-25058 is a medium-severity vulnerability in Twitter-Post-Fetcher, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in Twitter-Post-Fetcher up to 17.x. This affects an unknown part of the file js/twitterFetcher.js of the component Link Target Handler. The manipulation leads to use of web link to untrusted target with window.opener access. It is possible to initiate the attack remotely. Upgrading to version 18.0.0 is able to address this issue. The name of the patch is 7d281c6fb5acbc29a2cad295262c1f0c19ca56f3. It is recommended to upgrade the affected component. The identifier VDB-217017 was assigned to this vulnerability.

Weakness: CWE-1022 (Use of Web Link to Untrusted Target with window.opener Access)

## Which versions are affected by CVE-2018-25058?

2 open source packages ship an affected version, including twitter-fetcher-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twitter-fetcher-js` | npm | All versions | 18.0.0 |
| `twitter-fetcher-js` | npm | All versions | 18.0.0 |

Products: Twitter-Post-Fetcher Project Twitter-Post-Fetcher.

## How do I fix CVE-2018-25058?

Upgrade twitter-fetcher-js to 18.0.0 or later.

## Is CVE-2018-25058 being exploited?

There is no known exploitation of CVE-2018-25058 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25058 and fix it if it is affected.

What it is: CVE-2018-25058 is a medium-severity vulnerability in Twitter-Post-Fetcher, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-25058 in the wild and no public exploit code.

Affected packages and fixed versions:
- twitter-fetcher-js (npm): affected all versions; fixed in 18.0.0
- twitter-fetcher-js (npm): affected all versions; fixed in 18.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25058/ (Markdown: https://insights.sbomify.com/CVE-2018-25058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25058
- OSV: https://osv.dev/vulnerability/CVE-2018-25058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25058/
Summaries are generated and may contain mistakes; the official description above is the record.
