CVE-2018-25061 rgb2hex redos

Medium 4.3 Published Updated

Remote attackers can cause denial of service in the rgb2hex library via inefficient regular expression complexity, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-25061?

CVE-2018-25061 is a medium-severity denial of service vulnerability in rgb2hex, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in rgb2hex up to 0.1.5. It has been rated as problematic. This issue affects some unknown processing. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 0.1.6 is able to address this issue. The patch is named 9e0c38594432edfa64136fdf7bb651835e17c34f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217151.

Weakness: CWE-1333

Which versions are affected by CVE-2018-25061?

2 open source packages ship an affected version, including rgb2hex. It affects 1 product.

PackageAffectedFixed in
rgb2hex npmAll versions0.1.6
rgb2hex npmAll versions0.1.6

Products include Rgb2hex Project Rgb2hex.

How do I fix CVE-2018-25061?

Upgrade rgb2hex to 0.1.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-25061 being exploited?

There is no known exploitation of CVE-2018-25061 in the wild and no public exploit code.

Sources

Also known as GHSA-7599-fqgm-v84p.

Is CVE-2018-25061 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free