{"answers":{"affected":"2 open source packages ship an affected version, including rgb2hex. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25061 in the wild and no public exploit code.","fix":"Upgrade rgb2hex to 0.1.6 or later.","what":"CVE-2018-25061 is a medium-severity denial of service vulnerability in rgb2hex, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-25061 and fix it if it is affected.\n\nWhat it is: CVE-2018-25061 is a medium-severity denial of service vulnerability in rgb2hex, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-25061 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rgb2hex (npm): affected all versions; fixed in 0.1.6\n- rgb2hex (npm): affected all versions; fixed in 0.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25061/ (Markdown: https://insights.sbomify.com/CVE-2018-25061/index.md)","id":"CVE-2018-25061","markdown":"https://insights.sbomify.com/CVE-2018-25061/index.md","name":"CVE-2018-25061","record":{"aliases":["GHSA-7599-fqgm-v84p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm rgb2hex library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in the rgb2hex library via inefficient regular expression complexity, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"rgb2hex","vendor":"rgb2hex_project"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability was found in rgb2hex up to 0.1.5. It has been rated as problematic. This issue affects some unknown processing. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 0.1.6 is able to address this issue. The patch is named 9e0c38594432edfa64136fdf7bb651835e17c34f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217151.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rgb2hex redos","id":"CVE-2018-25061","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"flar2 ElementalX ipsec xfrm_user.c xfrm_dump_policy_done denial of service","id":"CVE-2018-25062"},"packages":[{"ecosystem":"npm","fixed":["0.1.6"],"introduced":["0"],"last_affected":[],"package":"rgb2hex","purl":null,"source":"GHSA-7599-fqgm-v84p"},{"ecosystem":"npm","fixed":["0.1.6"],"introduced":["0"],"last_affected":[],"package":"rgb2hex","purl":"pkg:npm/rgb2hex","source":"GHSA-7599-fqgm-v84p"}],"prev":{"headline":"Macaron csrf csrf.go missing secure attribute","id":"CVE-2018-25060"},"products":["rgb2hex"],"published":"2022-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in the rgb2hex library via inefficient regular expression complexity, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2018-25061/"}