# CVE-2018-25061: rgb2hex redos

> Remote attackers can cause denial of service in the rgb2hex library via inefficient regular expression complexity, requiring an upgrade to fix.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2022
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7599-fqgm-v84p

## What is CVE-2018-25061?

CVE-2018-25061 is a medium-severity denial of service vulnerability in rgb2hex, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in rgb2hex up to 0.1.5. It has been rated as problematic. This issue affects some unknown processing. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 0.1.6 is able to address this issue. The patch is named 9e0c38594432edfa64136fdf7bb651835e17c34f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217151.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2018-25061?

2 open source packages ship an affected version, including rgb2hex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rgb2hex` | npm | All versions | 0.1.6 |
| `rgb2hex` | npm | All versions | 0.1.6 |

Products: Rgb2hex Project Rgb2hex.

## How do I fix CVE-2018-25061?

Upgrade rgb2hex to 0.1.6 or later.

## Is CVE-2018-25061 being exploited?

There is no known exploitation of CVE-2018-25061 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25061 and fix it if it is affected.

What it is: CVE-2018-25061 is a medium-severity denial of service vulnerability in rgb2hex, published on 31 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25061 in the wild and no public exploit code.

Affected packages and fixed versions:
- rgb2hex (npm): affected all versions; fixed in 0.1.6
- rgb2hex (npm): affected all versions; fixed in 0.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25061/ (Markdown: https://insights.sbomify.com/CVE-2018-25061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25061
- OSV: https://osv.dev/vulnerability/CVE-2018-25061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25061/
Summaries are generated and may contain mistakes; the official description above is the record.
