{"answers":{"affected":"2 open source packages ship an affected version, including nodebatis. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25066 in the wild and no public exploit code.","fix":"Upgrade nodebatis to 2.2.0 or later.","what":"CVE-2018-25066 is a medium-severity SQL injection vulnerability in PeterMu nodebatis, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-25066 and fix it if it is affected.\n\nWhat it is: CVE-2018-25066 is a medium-severity SQL injection vulnerability in PeterMu nodebatis, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-25066 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nodebatis (npm): affected all versions; fixed in 2.2.0\n- nodebatis (npm): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25066/ (Markdown: https://insights.sbomify.com/CVE-2018-25066/index.md)","id":"CVE-2018-25066","markdown":"https://insights.sbomify.com/CVE-2018-25066/index.md","name":"CVE-2018-25066","record":{"aliases":["GHSA-8ph8-9q2j-c3rq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js SQL library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary SQL commands via the nodebatis library, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"nodebatis","vendor":"nodebatis_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability was found in PeterMu nodebatis up to 2.1.x. It has been classified as critical. Affected is an unknown function. The manipulation leads to sql injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 6629ff5b7e3d62ad8319007a54589ec1f62c7c35. It is recommended to upgrade the affected component. VDB-217554 is the identifier assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PeterMu nodebatis sql injection","id":"CVE-2018-25066","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"JoomGallery Image Sort default.php sql injection","id":"CVE-2018-25067"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"nodebatis","purl":null,"source":"GHSA-8ph8-9q2j-c3rq"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"nodebatis","purl":"pkg:npm/nodebatis","source":"GHSA-8ph8-9q2j-c3rq"}],"prev":{"headline":"Wikimedia mediawiki-extensions-I18nTags Unlike Parser I18nTags_body.php cross site scripting","id":"CVE-2018-25065"},"products":["nodebatis"],"published":"2023-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["PeterMu"]},"summary":"An attacker can execute arbitrary SQL commands via the nodebatis library, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2018-25066/"}