# CVE-2018-25066: PeterMu nodebatis sql injection

> An attacker can execute arbitrary SQL commands via the nodebatis library, potentially reading or modifying database contents.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8ph8-9q2j-c3rq

## What is CVE-2018-25066?

CVE-2018-25066 is a medium-severity SQL injection vulnerability in PeterMu nodebatis, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in PeterMu nodebatis up to 2.1.x. It has been classified as critical. Affected is an unknown function. The manipulation leads to sql injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 6629ff5b7e3d62ad8319007a54589ec1f62c7c35. It is recommended to upgrade the affected component. VDB-217554 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-25066?

2 open source packages ship an affected version, including nodebatis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebatis` | npm | All versions | 2.2.0 |
| `nodebatis` | npm | All versions | 2.2.0 |

Products: Nodebatis Project Nodebatis.

## How do I fix CVE-2018-25066?

Upgrade nodebatis to 2.2.0 or later.

## Is CVE-2018-25066 being exploited?

There is no known exploitation of CVE-2018-25066 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-25066 and fix it if it is affected.

What it is: CVE-2018-25066 is a medium-severity SQL injection vulnerability in PeterMu nodebatis, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-25066 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebatis (npm): affected all versions; fixed in 2.2.0
- nodebatis (npm): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-25066/ (Markdown: https://insights.sbomify.com/CVE-2018-25066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-25066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-25066
- OSV: https://osv.dev/vulnerability/CVE-2018-25066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-25066/
Summaries are generated and may contain mistakes; the official description above is the record.
