{"answers":{"affected":"2 open source packages ship an affected version, including com.anrisoftware.globalpom:globalpomutils. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-25068 in the wild and no public exploit code.","fix":"Upgrade com.anrisoftware.globalpom:globalpomutils to 4.5.1 or later.","what":"CVE-2018-25068 is a medium-severity vulnerability in devent globalpom-utils, published on 6 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-25068 and fix it if it is affected.\n\nWhat it is: CVE-2018-25068 is a medium-severity vulnerability in devent globalpom-utils, published on 6 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-25068 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.anrisoftware.globalpom:globalpomutils (Maven): affected all versions; fixed in 4.5.1\n- com.anrisoftware.globalpom:globalpomutils (Maven): affected all versions; fixed in 4.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-25068/ (Markdown: https://insights.sbomify.com/CVE-2018-25068/index.md)","id":"CVE-2018-25068","markdown":"https://insights.sbomify.com/CVE-2018-25068/index.md","name":"CVE-2018-25068","record":{"aliases":["GHSA-jjvp-wfp8-rv69"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java utility library","requires_auth":"low_privilege","summary":"Insecure temporary file creation in globalpom-utils allows remote attackers to read or modify sensitive data via race conditions.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"globalpom-utils","vendor":"globalpom-utils_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-377","name":"DEPRECATED: Insecure Temporary File"}],"description":"A vulnerability has been found in devent globalpom-utils up to 4.5.0 and classified as critical. This vulnerability affects the function createTmpDir of the file globalpomutils-fileresources/src/main/java/com/anrisoftware/globalpom/fileresourcemanager/FileResourceManagerProvider.java. The manipulation leads to insecure temporary file. The attack can be initiated remotely. Upgrading to version 4.5.1 is able to address this issue. The patch is identified as 77a820bac2f68e662ce261ecb050c643bd7ee560. It is recommended to upgrade the affected component. VDB-217570 is the identifier assigned to this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"devent globalpom-utils FileResourceManagerProvider.java createTmpDir temp file","id":"CVE-2018-25068","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Netis Netcore Router hard-coded password","id":"CVE-2018-25069"},"packages":[{"ecosystem":"Maven","fixed":["4.5.1"],"introduced":["0"],"last_affected":[],"package":"com.anrisoftware.globalpom:globalpomutils","purl":null,"source":"GHSA-jjvp-wfp8-rv69"},{"ecosystem":"Maven","fixed":["4.5.1"],"introduced":["0"],"last_affected":[],"package":"com.anrisoftware.globalpom:globalpomutils","purl":"pkg:maven/com.anrisoftware.globalpom/globalpomutils","source":"GHSA-jjvp-wfp8-rv69"}],"prev":{"headline":"JoomGallery Image Sort default.php sql injection","id":"CVE-2018-25067"},"products":["globalpom-utils"],"published":"2023-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["devent"]},"summary":"Insecure temporary file creation in globalpom-utils allows remote attackers to read or modify sensitive data via race conditions.","url":"https://insights.sbomify.com/CVE-2018-25068/"}